C++ Class Template Specialization Hackerrank Solution in C++. You are given a main function which reads the enumeration values for two different types as input and then prints out the corresponding enumeration names. Write a class template that can provide the names of the enumeration values for both types. If the enumeration value is not valid, then print unknown.
Input Format
The first line contains t, the number of test cases.
Each of the t subsequent lines contains two space-separated integers. The first integer is a colour value, c, and the second integer is a fruit value, f.
Output Format
The locked stub code in your editor prints t lines containing the colour name and the fruit name corresponding to the input enumeration index.
Sample Input
2
1 0
3 3
Sample Output
green apple
unknown unknown
Explanation
Since t = 2, there are two lines of output.
The two input index values, 1 and 0, correspond to green in the colour enumeration and apple in the fruit enumeration. Thus, we print green apples.
The two input values, 3 and 3, are outside of the range of our enums. Thus, we print unknown.
Submit your solution here: Click here
C++ Class Template Specialization Hackerrank Solution in C++
#include <iostream>
using namespace std;
enum class Fruit
{
apple, orange, pear
};
enum class Color
{
red, green, orange
};
template < typename T > struct Traits;
// Define specializations for the Traits class template here.
template < >
struct Traits < Fruit>
{
public: static
const char *name(int index)
{
Fruit f = (Fruit) index;
switch (f)
{
case Fruit::apple:
return "apple";
case Fruit::orange:
return "orange";
case Fruit::pear:
return "pear";
}
return "unknown";
}
};
template < >
struct Traits < Color>
{
public: static
const char *name(int index)
{
Color c = (Color) index;
switch (c)
{
case Color::red:
return "red";
case Color::green:
return "green";
case Color::orange:
return "orange";
}
return "unknown";
}
};
int main()
{
int t = 0;
std::cin >> t;
for (int i = 0; i != t; ++i)
{
int index1;
std::cin >> index1;
int index2;
std::cin >> index2;
cout <<Traits<Color>::name(index1) << " ";
cout <<Traits<Fruit>::name(index2) << "\n";
}
}
The Output of C++ Class Template Specialization Solution
Similar to C++ Class Template Specialization
- Attending Workshops Hackerrank Solution in C++
- Overload Operators Hackerrank Solution in C++
- Abstract Classes - Polymorphism Hackerrank Solution in C++
- Exceptional Server Hackerrank Solution in C++
- Inherited Code Hackerrank Solution in C++
- Box It Hackerrank Solution in C++
- Classes and Objects Hackerrank Solution in C++
- Class Hackerrank Solution in C++
- Virtual Functions Hackerrank Solution in C++
- C++ Class Templates Hackerrank Solution in C++
- Operator Overloading Hackerrank Solution in C++
- Preprocessor Solution Hackerrank Solution in C++
- Multi-Level Inheritance Hackerrank Solution in C++
0 Comments: