Maps STL Hackerrank Solution in C++. Maps are a part of the C++ STL. Maps are associative containers that store elements formed by a combination of a key value and a mapped value, following a specific order. The mainly used member functions of maps are:
Map Template:
std::map <key_type, data_type>
Declaration:
map<string,int>m; //Creates a map m where key_type is of type string and data_type is of type int.
Size:
int length=m.size(); //Gives the size of the map.
Insert:
m.insert(make_pair("hello",9)); //Here the pair is inserted into the map where the key is "hello" and the value associated with it is 9.
Erasing an element:
m.erase(val); //Erases the pair from the map where the key_type is val.
Finding an element:
map<string,int>::iterator itr=m.find(val); //Gives the iterator to the element val if it is found otherwise returns m.end() .
Ex: map<string,int>::iterator itr=m.find("Maps"); //If Maps is not present as the key value then itr==m.end().
Accessing the value stored in the key:
To get the value stored off the key "MAPS" we can do m["MAPS"] or we can get the iterator using the find function and then by itr->second we can access the value.
To know more about maps click Here.
You are appointed as the assistant to a teacher in a school and she is correcting the answer sheets of the students. Each student can have multiple answer sheets. So the teacher has Q queries:
- X Y: Add the mark Y to the student whose name is X.
- X: Erase the marks of the students whose name is X.
- X: Print the marks of the students whose name is X. (If X didn't get any marks print ).)
Input Format
The first line of the input contains Q where Q is the number of queries. The next Q lines contain 1 query each. The first integer, the type of each query is the type of the query. If the query is of type 1, it consists of one string and an integer X and Y where X is the name of the student and Y is the marks of the student. If the query is of type 2 or 3, it consists of a single string X where X is the name of the student.
Constraints
1 <= Q <= 10^5
1 <= type <= 3
1 <= |Y| <= 6
1 <= Y <= 10^3
Output Format
For queries of type 3 print the marks of the given student.
Sample Input
7
1 Jesse 20
1 Jess 12
1 Jess 18
3 Jess
3 Jesse
2 Jess
3 Jess
Sample Output
30
20
0
Maps are a part of the C++ STL ( Standard Template Library ). Maps are associative containers that store elements formed by a combination of a key value and a mapped value, following a specific order. The mainly used member functions of maps are:
Submit your solution here: Click here
Maps STL Hackerrank Solution in C++
#include <cmath>
#include <cstdio>
#include <vector>
#include <iostream>
#include <set>
#include <map>
#include <algorithm>
using namespace std;
int main()
{
/*vist http://www.programmingwithbasics.com */
map<string, int> s;
int q;
cin >> q;
for (int i = 0; i < q; i++)
{
int t, n, m;
cin >> t;
switch (t)
{
case 1:
{
string name;
int marks;
cin >> name >> marks;
map<string, int>::iterator itr = s.find(name);
if (itr == s.end())
s.insert(make_pair(name, marks));
else
itr->second += marks;
break;
}
case 2:
{
string name;
cin >> name;
s.erase(name);
break;
}
case 3:
{
string name;
cin >> name;
map<string, int>::iterator itr = s.find(name);
if (itr == s.end())
cout << "0" << endl;
else
cout << itr->second << endl;
break;
}
}
}
return 0;
}
The Output of Maps STL Hackerrank Solution
Similar to Maps STL
- Sets STL Hackerrank Solution in C++
- Lower Bound STL Hackerrank Solution in C++
- Vector Erase Hackerrank Solution in C++
- Magic Spells Hackerrank Solution in C++
- Vector Sort Hackerrank Solution in C++
- Structs Hackerrank Solution in C++
- Variable Sized Arrays Hackerrank Solution in C++
- Conditional Statements in C++ Hackerrank Solution
- Reverse a Linked List Hackerrank Solution
- Input And Output Hackerrank Solution in C++
- Solve Me First Hackerrank Solution in C & C++
- A Very Big Sum Hackerrank Solution C++
0 Comments: